05/15/11 - Playstation Info Not Working

Tarvis

Yeah, that's right.
Original poster
Administrator
Nov 10, 2003
8,434
735
As of early this morning, the Playstation information is not displaying correctly (or at all).

I'm not sure if the problem will fix itself automatically, but the problem is most likely due to the PSN being brought back up and changes on Sony's end. I might have to update the API on the server whenever there is an update released.

I'll post again when I find out more.
 

InfamousVuk

Deku Scrub
Mar 2, 2011
15
5
Figured so much, but it's odd to see some accounts showing info, and some not.

Thanks for the heads up.
 

Logan

Administrator
Nov 10, 2003
12,019
935
All of them weren't showing up when I ran the sig output this morning, but now I see Bayli's.

HMM
 

Logan

Administrator
Nov 10, 2003
12,019
935
Now mine is correct as well. I'mma go for a run and come back and see whats up.
 

Chris

Sweet Little Lies
Senior Member
Jan 15, 2011
2,157
165
Pretty sure Travis (admin) is currently working on it!
 

Tarvis

Yeah, that's right.
Original poster
Administrator
Nov 10, 2003
8,434
735
I paid $50 (which I dont have luls) for a new API last night. Current API just acts like it has trouble connecting, but I want to get this fixed asap.

PSN also kept telling me it was under maitenance or giving me errors last night, so Im not even sure if their service is working correctly.

Anyways I currently have an unreliable half fix implimented that wont show all PSN info but it will at least show some.
 

rman

The Grapist!!
Mar 8, 2011
290
35
YouDaManJesus.jpg
 

InfamousVuk

Deku Scrub
Mar 2, 2011
15
5
Better just wait till PSN is up and working properly.
It won't kill anyone if their achievements/trophies aren't showing in real-time.
 

Tarvis

Yeah, that's right.
Original poster
Administrator
Nov 10, 2003
8,434
735
I received the new API this morning. I will have to compile it, and unfortunately im at work until this evening.
 

FiOth

Dedicated Gamer
May 10, 2011
121
35
When I first saw the blanks in my sig I was sure it had something to do with the re-activation of PSN. Now most services update normally (like raptr) but there is a slight chance it has something to do with region or restrictions. You can wait until the store is back up as well and try to reconfigure it then.
 

Tarvis

Yeah, that's right.
Original poster
Administrator
Nov 10, 2003
8,434
735
It should be showing now.

However the server I host the API is not the same one that hosts this website as I havent been able to get it to work through mono on this server.

Unfortunately the server that hosts the API seems to be very slow at times. Which causes it to time out and cause the issue where nothing is being entered for PS3.

On the update scripts, I have some form of protection from this where it wont update the avatar/games if the script returns nothing. Unfortunately, this will not protect the script that the users use as both will return null results.

I've spent as much time as I've been able trying to get this script working on the main site as this would most likely stop this from happening, but time for me is very limited and numerous support queries and even offers of paying someone to fix it has yet to accomplish anything.
 

Tarvis

Yeah, that's right.
Original poster
Administrator
Nov 10, 2003
8,434
735
I purchased another(GAH) server for this PS3 API.

Is it working better?
 

Casey

I'M A GAY SON!
Senior Member
Nov 10, 2003
2,976
165
Jeez travis!

Where are you getting all this damn money?